Подключение jQuery библиотеки к WordPress

Сайт OnWordpress.ru продается

Оптимальная цена 300 000 рублей

Подробнее
Подключить Jquery библиотеку

Для работы Java и jQuery скриптов на WordPress сайте необходимы соответствующие библиотеки. По умолчанию Worpress уже включает в себя все необходимые библиотеки для работы плагинов. Подключение jQuery в WordPress производится автоматически , поэтому нет никакой необходимости подключать библиотеки других версий вручную. Но тем не менее, это возможно сделать.

Как подключается jquery к WordPress

В WordPress библиотека jQuery подключается автоматически в шаблоне с помощью php кода:

<?php wp_head(); ?>

Этот код генерирует различный HTML код, включая следующий:

 <script type='text/javascript' src='http://www.ваш_домен.ru/wp-includes/js/jquery/jquery.js?ver=1.7.2'></script>

Именно этот код отвечает за подключение JQuery библиотеки в WordPress. В таком случае, казалось бы разумным ручное подключение jQuery библиотеки другой версии с помощью подобного кода:

<script type="text/javascript" src="http://code.jquery.com/jquery-1.8.1.js"></script>

Но библиотека jQuery данной версии будет работать до тех пор, пока не потребуется библиотека другой версии. В таком случае, есть шанс возникновения конфликта.

Подключение JQuery к WordPress правильным способом

Чтобы избежать конфликта, но при этом использовать ту версию библиотеки, которая необходима, нужно воспользоваться правильным способом подключения jQuery в файле functions.php:

<?php
function my_jquery_scripts() {
    wp_deregister_script( 'jquery' );
    wp_register_script( 'jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js');
    wp_enqueue_script( 'jquery' );
}    

add_action( 'wp_enqueue_scripts', 'my_jquery_scripts' );
?>

В данном случае сначала дезактивируется штатная библиотека, затем подключается jQuery библиотека нужной версии с сервера Google.

Расскажите друзьям
Нравится блог? - Читайте ВКонтакте
Ответим на Ваши вопросы в комментариях